My Grocery Price Book Blog

The tech story behind the app and tools

Upgraded Site to use Rails 5

I must say that upgrading from Rails 4.2 to Rails 5.0 has been way smoother than previous rails. Upgrading from 3.2 to 4.0 was hard and upgrading from 2.3 to 3.0 was a plain nightmare. Hands down to the Rails core team this time around, they have really done a Great job.

I have managed to upgrade My Grocery Price Book to Rails 5 already and even remove all deprecation warning.

If you plan on upgrading soon, Rails Guides is a really good place to start.

If you can't do the whole upgrade in one go, have a look at this Gist which will enable you to do the upgrade piece meal.

Happy upgrading